Rebuilding degraded simple mirror volume (“The plex is missing”)

Welcome to Programming Tutorial official website. Today - we are going to cover how to solve / find the solution of this error Rebuilding degraded simple mirror volume (“The plex is missing”) on this date .

I’m interested in rebuilding a basic degraded dynamic volume without resorting to trivially breaking/deleting and re-creating the volume.

There is no concern about data loss. I hope to use this as a learning opportunity to better understand Windows dynamic disks/volumes.

The situation: A dynamic volume under Windows 8 consisting of two physical drives in a mirror configuration has been running in degraded mode. The first plex of the mirror volume is labeled by Windows as “Failed Redundancy”. The former entry for the second plex of the same volume remains and is labeled as “Missing”. I suspect that the fault was interruption of power to second device (the drive cage has some chintzy power switches for each drive). Attempting to reactivate the volume yields the error message The plex is missing. This is a little surprising as the second disk is recognized by the system. It has a recognized dynamic volume, but is labeled “Foreign” and displays no detail about the volume (which is more or less consistent with the error message).

The Disk Management console has an option to “Import Foreign Disks,” but it is not clear what effect it will have. Early in my search for information I read an account that this will import contents as new distinct volumes rather than reconciling with existing volumes. What will this action do?

Is there a Windows equivalent to Linux’s mdadm to manually manipulate dynamic volumes or at least get a better sense of how Windows conceptualizes these devices?

Answer

“Import Foreign Disks” did not reassociate (rebuild) the degraded volume. I believe the foreign disk was no longer marked as “Foreign”, but the first plex remained as “Failed Redudancy” and the second plex “Missing”.

There weren’t any other actions available in the management interface, so I ultimated deleted and re-created the volume.